NanDigits中国

位置:文档/GOF用户手册/第四章 GUI模式

上一章 脚本模式

4 GUI Mode Detail Features

4.1 GofViewer
4.1.1 Log Window
4.1.2 File Menu
4.1.3 Find Menu
4.1.4 Commands Menu
4.1.5 Options Menu
4.1.6 Help Menu
4.1.7 Keyboard Shortcuts
4.1.8 Selection Status
4.1.9 Netlist Window Pop Menu
4.1.10 Hierarchy Window Pop Menu
4.2 GofTrace
4.2.1 Mouse buttons usage
4.2.2 File Menu
4.2.3 Schematic Menu
4.2.4 Commands Menu
4.2.5 Options Menu
4.2.6 Help Menu
4.2.7 Keyboard Shortcuts
4.2.8 Selection Status
4.2.9 GofTrace Pop Menu
4.3 GofECO
4.3.1 ECO Menu
4.3.2 Metal Only ECO
4.4 LayoutViewer
4.4.1 File Menu
4.4.2 Commands Menu
4.4.3 OptionsMenu
4.4.4 Help Menu
4.4.5 LayoutViewer Pop Menu
4.4.6 Keyboard and mouse combination
4.4.7 Mouse operations
4.4.8 Select color buttons
4.4.9 Search function

4.1 GofViewer

When GOF is run without '-run' and '-shell' option, it goes into GUI mode.

gof -lib t65nm.lib -lib io.liblong_port.v

GofViewer is the first window after GOF starts up GUI interface.

img

Figure 17: GofViewer Window

4.1.1 Log Window

If there errors or warnings in loading the database, Log Window pops up

img

Figure 18: Log Window

4.1.2 File Menu

4.1.2.1 Load Design

Users can input netlist files and design files through the Load Design command.

4.1.2.2 Reload Design

If any netlist file or design file has been updated during GOF session, this command can be used to reload the design.

4.1.2.3 Open Other Netlist

This command loads another netlist file to create a new hierarchical tree. The hierarchy tree is listed in the hierarchy list window. The command is useful when users want to draw circuits from different netlist file on the same schematic which is good for logic comparison in netlist debug scenario such as LEC failures analysis.

4.1.2.4 Open Log Window

The command opens log file in a text window.

4.1.2.5 Exit

Exit command.

4.1.3 Find Menu

4.1.3.1 Search

This command searches for the matching string in the netlist text window.

4.1.3.2 Goto Line Number

GOF loads only one module in the netlist text window when the netlist file is hierarchical with multiple modules. The command loads the corresponding module into the text window and highlight the line with the specific number in the netlist file.

4.1.3.3 Report Area

This command reports the design area. The command requires standard library files to be loaded which include leaf cell area information.

4.1.3.4 Report Leakage

This command reports the leakage power in the design. Same as the Report Area command it requires standard libraries.

4.1.3.5 Report Leaf Cells

This command reports the leaf cell type and numbers in the design.

4.1.3.6 Report Submodules

This command reports the hierarchical sub-modules in the design.

4.1.3.7 Statistic of Current Design

This command reports the statistic of the current design. It pops up an option window for interactivity from users.

4.1.3.8 List Library

The command lists the libraries and leaf cells in each library.

4.1.3.9 List Context for Leaf Cell

This command pops up an entry window for users to input leaf cell name string, wild card can be accepted. All leaf cells matching the string is listed. If there is only one cell matched, the detail property is listed.

4.1.4 Commands Menu

4.1.4.1 Launch GofTrace Schematic

This command launches GofTrace Schematic, if any instance or net string is highlighted in the netlist window, the instance or the driver of the net is drawn on the schematic. Otherwise, the schematic is empty.

4.1.4.2 Launch GofTrace with Gate

This command pops up an entry window for users to input a string to load a specific instance. For example, 'u_abc/U123'. Click 'OK' button on the pop window, GofTrace Schematic is launched.

4.1.4.3 Launch Layout Viewer

This command launches Layout Viewer window, if any instance or net string is highlighted in the netlist window, the instance or the driver of the net is highlighted on the Layout Viewer window. The command requires that physical files to be loaded. Both def and lef files should be loaded before launching Layout Viewer, otherwise a warning window pops up for the missing physical files.

4.1.4.4 Launch GofCall Script Interface

This command launches GofCall window to run scripts or other interactive command.

4.1.4.5 Switch to GOF Shell Mode

This command exits GUI mode and switches to shell mode. It has 'GOF >' shell interface in shell mode.

4.1.4.6 Spare Cells

This command group processes Spare cells in metal ECO. Warning! GUI metal ECO is used for visually checking the possibility of metal ECO. The script mode metal ECO is recommended.

This command extracts spare cells from netlist file. A pop window appears for spare gates pattern. The default is 'spare_/'.

img

Figure 19: Spare Cell Pattern

Click 'OK' to extract spare instances from the netlist, and a pop text window appears to list all spare gate instances. Save the list to a spare list file for later usage.

img

Figure 20: Spare cell list

This command loads in the spare cells file created by the above command.

4.1.4.7 Launch Files Compare Window

This command launches netlist files compare window. The netlist compare function can do more than simple Linux 'diff' command.

4.1.4.8 Process Timing Violations

This command processes Prime Time report file. Read this PDF file for the use case.

nandigits.com/use_cases/gof_timing_analysis.pdf

4.1.4.9 SDF

This command group processes SDF file for delay information interactivity.

GOF reads in SDF Index File instead of SDF file itself, since SDF can have huge size. Once the index file is created it can be reused next time and loaded in much faster.

This command loads in already created SDF Index File.

4.1.5 Options Menu

4.1.5.1 Hierarchy Window Font

Check GofViewer for the hierarchy list window position

Increase font size in the hierarchy list window.

Decrease font size in the hierarchy list window.

4.1.5.2 Netlist Window Font

Netlist window locates in the right side of GofViewer window. Check GofViewer for the netlist text window position

Increase the font size in netlist window.

Decrease font size in netlist window.

4.1.5.3 Dump Waveform Restore File

An option window pops up for users to choose which dump restore file to be saved. It's useful for netlist simulation debug. When one format box is checked in pop menu, 'Write Waveform Restore File' item is presented on the top when one net is selected in the netlist window.

4.1.5.4 Setup

Integration of various setup information.

4.1.6 Help Menu

4.1.6.1 General

General help information.

4.1.6.2 About

About Gates On the Fly.

4.1.6.3 nandigits.com/gof_manual.php

Visit the website for this manual.

4.1.6.4 Read Ethernet Mac Address

Read out MAC address. When users decide to purchase licenses or ask for evaluation licenses, MAC address is required to generate GOF licenses.

4.1.7 Keyboard Shortcuts

4.1.7.1 Access Menu

Press key 'Alt' and underlined letter in menu.

4.1.7.2 Functions access

4.1.8 Selection Status

Click mouse-left-button on netlist text window, the object which can be net, instance or module under the cursor is highlighted. Netlist window pop menu has different content according to the selection status. Pressing keys Ctrl-a can have all content in the netlist window selected. Press mouse-left-button and don't release, move mouse down to select multiple lines.

4.1.9 Netlist Window Pop Menu

Click mouse-right-button and release, a pop menu appears under the cursor. The menu content varies with the selection status in the netlist window.

4.1.9.1 Search

Search for a string in the netlist window. Keyboard shortcut is Ctrl-f.

4.1.9.2 Copy Selected to

Copy the selected object (net or instance) to new schematic window or existing schematic window.

Copy the selected object to a new schematic.

Copy the selected object to an existing schematic window.

4.1.9.3 Driver of the selected net

Trace to the driver of the selected net. The netlist window shows the instance that drives the net and mark the driven net.

4.1.9.4 List Connectivity of the selected net

Pop up a window to list the connectivity of the selected net.

4.1.9.5 List Fanin EndPoints

Pop up a window to list the fanin endpoints including flops and input ports that drive the selected net.

4.1.9.6 List Fanout EndPoints

Pop up a window to list the fanout endpoints including flops and output ports that are driven by the selected net.

4.1.9.7 Parent Module

Go to the definition location of the parent module calling the current module. It's only active in sub-modules, not in root top level module.

4.1.9.8 List Context

List the context of the selected object which can be net, instance or module.

4.1.10 Hierarchy Window Pop Menu

Click mouse-right-button and release, a pop menu appears under the cursor. The menu content varies with the selection status in the hierarchy window.

4.1.10.1 Show Definition

Open the module content and display it in the netlist window.

4.1.10.2 Show Calling

Open the parent module and highlight the instantiation location.

4.1.10.3 Report Area of the selected design

See Report Area

4.1.10.4 Report Leakage of the selected design

See Report Leakage

4.1.10.5 Report Leaf Cells of the selected design

See Report Leaf Cells

4.1.10.6 Report Submodules of the selected design

See Report Submodules

4.1.10.7 Statistic of the selected design

See Statistic of Current Design

4.1.10.8 Edit Module of the selected design

Edit the module by using edit tool defined in menu Options->Setup->Misc->'Edit tool'. It asks for a directory for storing temporary files.

4.1.10.9 Save Module of the selected design

After editing, the edited modules can be saved into a file.

4.1.10.10 Goto Line Number

4.2 GofTrace

GofTrace is an incremental schematic engine. Users control how to expand the schematic by clicking the input/output pins of gates with mouse-middle-button. Users can adjust the positions of the gates on the schematic any time by mouse-left-button.

img

Figure 21: GofTrace Window

4.2.1 Mouse buttons usage

4.2.1.1 Mouse Left Button

Mouse left button is used to select object. Click on any object, it is highlighted to indicated being selected. Press 'ctrl' key and click on objects to select multiple objects. Press mouse left button and move the mouse to select multiple objects at one time.

4.2.1.2 Mouse Middle Button

Mouse middle button is used to trace the schematic. Click on input/output pins to expand the schematic. It used to do drag-drop function as well. In ECO mode, it's used to connect floating input pin to existing nets.

4.2.1.3 Mouse Right Button

Mouse right button is to popup menu.

4.2.2 File Menu

4.2.2.1 Save

Save the schematic to a file for future usage. The saved file has extension '.st' which can only be used by GOF in 'Open' schematic command shown below.

4.2.2.2 Open

Open schematic stored by Save command above.

4.2.2.3 Print

Print schematic to a printer or file. Printer Page Setup window pops up for the print scope setup. In Windows platform, users can select one of the printers configured in the system. In Linux platform, make sure 'lpr' command works.

4.2.2.4 Exit

Exit GofTrace window.

4.2.3 Schematic Menu

4.2.3.1 New Schematic

This command launches a new GofTrace schematic window.

4.2.3.2 List Gate

This command pops up a window for user to enter a string into the entry to find the matching instances. It accepts wildcards in both hierarchy name and instance name. For example, there are four hierarchical instances u_lane0, u_lane1, u_lane_2, u_lane3, each instance has spare modules with instance naming 'u_spare', and in each spare module AND gate has instance naming 'AND'. In order to find all spare AND gates, one can enter a string 'u_lane/u_spare/AND*'.

4.2.3.3 Load Gate

This command pops up a window for user to enter a string into the entry to load the matching instances onto the schematic. Same as 'List Gate' command above, it accepts wildcards. However, the total number of gates drown on the schematic should not exceed the threshold defined in Menu Options->Setup->Misc->'Gates number limit'.

4.2.3.4 Load Gate Driving Net

This command pops up a window for user to enter a string into the entry as the net name. The tool finds the driver of the net and draw the driver on the schematic.

4.2.3.5 List Selected Instances

Use mouse-left-button to select a bunch of objects (Instances or wires) on the schematic. Click this command to list all the selected instances' full hierarchical names in a pop window.

4.2.3.6 List Selected Wires

Use mouse-left-button to select a bunch of objects (Instances or wires) on the schematic. Click this command to list all the selected wires' full hierarchical names in a pop window.

4.2.3.7 List Selected Modules

Use mouse-left-button to select a bunch of objects (Instances or wires) on the schematic. Click this command to list all the selected gates' module name in a pop window.

4.2.3.8 List Selected Instances Definitions

Use mouse-left-button to select a bunch of objects (Instances or wires) on the schematic. Click this command to list all the selected instances' full definitions in a pop window.

4.2.3.9 List Selected Gates Types

Use mouse-left-button to select a bunch of objects (Instances or wires) on the schematic. Click this command to list logic type numbers of all the selected gates in pop window. For example, 'AND' gate has type 'and', inverter has type 'not'. The pop window can have information such as “Type 'not' has 11”.

4.2.3.10 Zoom In

This command can zoom in the schematic view. The maximum zoom in ratio is 100%. Keyboard shortcut for this command is key '+'.

4.2.3.11 Zoom Out

This command can zoom out the schematic view. The minimum zoom out ratio is 13%. Key board shortcut for this command is key '-'.

4.2.3.12 Zoom to

This command can directly select zoom ratio, the valid values are 100%, 67%, 44%, 30%, 20% and 13%.

4.2.3.13 Find Gates on Schematic

This command pops up a window for users to enter a string to find the matching instances on the schematic. It matches portion of the full name. For example, 'U' matches 'U0', 'U1' and 'U222'.

4.2.3.14 Find Nets on Schematic

This command pops up a window for users to enter a string to find the matching wires on the schematic. It matches portion of the full name. For example, 'Net0' matches 'Net0', 'Net011' and 'Net023'.

4.2.3.15 Undo Schematic Operations

This command is to undo schematic operations. Keyboard shortcut is Ctrl-z.

4.2.3.16 Place and Route

This command group is to automatically place the gates on the schematic and automatically route the wires.

This command is to do both placement and routing automatically.

This command is to do automatic placement only.

This command is to do automatic routing only.

This command is to reset all existing routes, all routed wires become straight.

4.2.3.17 Create PS/PDF File

This command is to create Postscript file or PDF file for the current view of the schematic. In Windows platform, only Postscript is support. On Linux platform both Postscript and PDF are supported.

4.2.4 Commands Menu

4.2.4.1 View Gates in Layout

This command launches layout viewer window. If some gates and wires are selected on the schematic, they are highlighted on the layout viewer. It requires DEF and LEF physical design files to be loaded.

4.2.4.2 Load Layout Files

This command is to load layout physical design files. They include DEF and LEF files. The command can be run several times to load the physical design file one by one. DEF and LEF files can be loaded by command line with -def and -lef options. Or they can be read in by API 'read_def' and 'read_lef' in GofCall script.

4.2.4.3 Launch GofCall Script Interface

This command launches GofCall Script Interface window.

4.2.4.4 Spare Cells

This command group handles spare cells in automatic metal ECO flow.

This command creates spare cells file.

This command loads the spare cells file created by the command above.

4.2.4.5 Launch Files Compare Window

This command launches netlist files compare window.

4.2.4.6 Process Timing Violations

This command launches Prime Time report file processing controller.

4.2.4.7 SDF

This command group handles SDF loading.

This command creates SDF file index file. GOF doesn't load the full SDF file, but SDF index file instead.

This command loads SDF index file created by the command above.

4.2.5 Options Menu

4.2.5.1 Increase Font Size

This command increases the font size on the schematic.

4.2.5.2 Decrease Font Size

This command decreases the font size on the schematic.

4.2.5.3 Show Port

This option makes port name visible.

4.2.5.4 Show Wire

This option makes wire name visible.

4.2.5.5 Show Title

This option makes gate title visible.

4.2.5.6 Show Type

This option makes gate type visible.

4.2.5.7 Show Connections

This option makes wires visible.

4.2.5.8 Show Comment

This option makes comments visible.

4.2.5.9 Dump Waveform Restore File

This command pops up a window to setup simulation waveform restore file. Four waveform restore file formats are supported.

If one or more of the formats are selected, GofViewer and GofTrace pop menus have 'Write Selected Nets to the Waveform Restore File' as the first item, when a net is selected.

4.2.5.10 Save String to Clipboard

This option enables saving string to clipboard when a wire or instance name is clicked by mouse-left-button.

4.2.5.11 Cursor Mode

This is normal mode of the schematic tracing.

4.2.5.12 Line Edit Mode

This mode sets cursor in editing wire connections mode. Press mouse-left-button on the straight wire connection and move, the line is pulled by the cursor until the mouse button is released.

4.2.5.13 Setup

The command pops up configuration window for the tool setup.

4.2.6 Help Menu

4.2.6.1 General

General help information.

4.2.6.2 About

About Gates On the Fly.

4.2.6.3 nandigits.com/gof_manual.php

Visit the website for the manual.

4.2.7 Keyboard Shortcuts

4.2.7.1 Access Menu

Press key 'Alt' and underlined letter in menu.

4.2.7.2 Functions access

4.2.8 Selection Status

Click mouse-left-button on the schematic window, the object which can be net, instance under the cursor is highlighted. GofTrace pop menu has different content according to the selection status. Pressing keys Ctrl-a can have all selected on the schematic. Press mouse-left-button on empty space, and don't release, move mouse down to select multiple objects.

4.2.9 GofTrace Pop Menu

Click mouse-right-button on GofTrace schematic, a menu pops up. The content of the menu varies as the selection status on the schematic.

4.2.9.1 Driver Until Non Buffer

Trace driver of an input pin. If the driver is a buffer or invert, the tracing will continue on the input pin of the buffer or invert, until the driver is non-buffer/invert. The feature can be used to trace the clock tree cells of a flop's clock input.

4.2.9.2 Drivers of Logic Cone

Logic Cone is the logic cluster between flops and ports, as shown in the following figure. Users should select the output flop or its pins to do logic cone extraction.

img

Figure 22: Logic Cone

Draw the whole logic cone on the schematic.

Display the whole logic cone in a pop up text window.

4.2.9.3 Copy Selected to

This command group does interactions between GofTrace windows and LayoutViewer windows.

Copy the selected items to a new schematic.

Copy the selected items to an existing schematic identified by ID Number.

Copy the selected items to a new launched LayoutViewer window. The selected circuit is marked on the LayoutViewer window.

Copy the selected items to an existing LayoutViewer window indentified by ID Number.

4.2.9.4 Nets Equivalence Check

The command needs Reference Netlist loaded.

Use mouse-left-button to select on a pin in implementation netlist and press 'ctrl' key to click mouse-left-button on the other pin in reference netlist. So that one pin in implementation netlist and the other comparing pin in reference netlist are selected at the same time.

Click mouse-right-button to popup menu and select "Equivalence Check for 'neta' vs 'netb'" command.

img

Figure 23: Nets Equivalence Check

When the check is done, a pop window shows if the nets are equivalent.

4.2.9.5 Find Logic Equivalent Nets

Wire names in RTL codes are normally optimized away in synthesis process. GOF has a way to retrieve them. A reference netlist with the wire names preserved should be synthesized. There are several ways to preserve wire names.

Reference Netlist should be loaded with Implementation Netlist.

Start GUI Window, load the preserved wires on a schematic window. Select the pin that drives the wire, right click mouse-right-button to popup menu. Select 'List Logic Equivalent Nets of ...' command.

img

Figure 24: List Logic Equivalent Nets

A popup window appears to list the nets that Logically Equal or Invert to the reference net. By popup menu on the window, the corresponding nets can be easily loaded into the schematic.

img

Figure 25: Logic Matching Nets

The feature is very convenient in manual ECO when the optimized wires have to be located in Implementation Netlist.

4.2.9.6 Find Circuit between Two Points

When two or more than two instances are selected on the schematic, the command item appears in the pop menu. This command finds the combination logic path between two instances.

4.2.9.7 Add Comments

This command adds comments entered by users on the schematic.

4.2.9.8 Find Gates on Schematic

This command pops up a window for users to enter a string to find the matching instances on the schematic. It matches portion of the full name. For example, 'U' matches 'U0', 'U1' and 'U222'.

4.2.9.9 Find Nets on Schematic

This command pops up a window for users to enter a string to find the matching wires on the schematic. It matches portion of the full name. For example, 'Net0' matches 'Net0', 'Net011' and 'Net023'.

4.2.9.10 Place and Route

This command group is to automatically place the gates on the schematic and automatically route the wires.

This command is to do both placement and routing automatically.

This command is to do automatic placement only.

This command is to do automatic routing only.

This command is to reset all existing routes, all routed wires become straight.

4.2.9.11 Find selected in GofViewer

This command finds the selected instance back in GofViewer netlist window, and highlights the instance in the netlist window.

4.2.9.12 Edit Gate Display

This command pops up a window for users to add or change comments associated with the gate and change the color of the gate.

4.2.9.13 List Logic for the Selected Leaf Cell

This command pops up a text window to list the logic of the selected leaf cell.

4.2.9.14 List Context for the Selected Leaf Cell

This command pops up a text window to list the library content of the selected leaf cell. The content includes the cell's pin definitions, area and timing.

4.2.9.15 List Definition for the Selected Instance

This command pops up a text window to list the instantiation of the selected instance.

4.2.9.16 Load Instance Similar to the Selected Instance

This command pops up an entry window with the current selected instance name pasted in the entry. So that user can do simple change to load other similar naming style instance onto the schematic.

4.2.9.17 Equivalent Symbol

This command changes the selected gate symbol display to the equivalent symbol according to DeMorgan's Laws. For example, NAND symbol is equivalent to Inputs Inverted OR symbol.

4.2.9.18 Delete

This command deletes the selected objects on the schematic. The object can be gates, wires and comments.

4.3 GofECO

GofECO uses the same window as GofTrace by enable ECO mode. The background color changes to light blue by default. The color can be configured by Menu Setup->GofECO->Color->BackGround. The ECO operation icons appear on the tool bar. GofECO uses the same menus GofTrace uses, besides the contents in ECO menu being activated.

img

Figure 26: GofECO Window

4.3.1 ECO Menu

4.3.1.1 Enable ECO and ECO Preferences

This option enable ECO mode, GofTrace switches to GofECO. A pop up window appears for inputting ECO setups.

img

Figure 27: ECO Preferences

4.3.1.2 Insert Gates

This command inserts gates in the selected wires. It requires one or more wires being selected on the schematic, before inserting gates. A 'Gate selection' window pops up for users to select proper type of gates and gate number. When multiple wires are selected and some wires have the same drivers, users can choose either one gate driving all shared wires or one gate driving each wire. Users are asked to choose the pin connections in 'Specify pin connections' window. The default pin connections setup can be used and users can modify the connections later on the schematic. Read this PDF use case for more detail.

gof_insert_buffers_inverters.pdf

4.3.1.3 Replace Gates

This command replaces the selected gates with a different type of gates. It requires one or more gates being selected on the schematic. If two or more than two gates are selected, they should have the same type. A 'Gate selection' window pops up for users to select proper type of gates to replace the selected ones. Users are asked to choose the pins connections in 'Specify pin connections' window. The default pin connections setup can be used and users can modify the connections later on the schematic.

4.3.1.4 Add Gates

This command adds new ECO gates on the schematic. A 'Gate selection' window pops up for users to select proper type of gate to add onto the schematic. The new ECO gates appear as output driving a new net and input floating. The hierarchy of the gate is undefined. When users connect one of the input pins to another existing gate or connect other gate's floating input to the ECO gate's output pin, the ECO gate gets the same hierarchy as the other gate. Read Add Connection for more detail.

4.3.1.5 Delete Selected Items

This command deletes the selected items. Users would be warned for deleting multiply objects at the same time.

4.3.1.6 Upsize Drive Strength

This command upsizes the selected gate to a higher drive strength gate with the same type. If there is no higher drive strength gate available, users would be warned with a pop up information window.

4.3.1.7 Downsize Drive Strength

This command downsizes the select gate to a lower drive strength gate with the same type. If there is no lower drive strength gate available, users would be warned with a pop up information window.

4.3.1.8 Undo ECO Operations

This command undoes the previous ECO operation, until no more ECO operation is in the pipeline.

4.3.1.9 Add Connection

There is no operation button/icon for Add Connection operation. Adding connection can only be done from a floating input pin to a output pin. User can press mouse-middle-button on a floating input pin, and don't release the mouse. Then move mouse to the destination output pin of the instance that user would like the wire connected to, release the button to make the connection to be created.

4.3.1.10 Save ECO

This command saves ECO result to a file. The supported file formats:

4.3.2 Metal Only ECO

Metal ECO only touches metal layers. Gates On the Fly provides four Metal Only ECO modes by combinations of setting up the options in ECO preference and loading DEF file.

4.3.2.1 Metal ECO, mode 1

User can add any type of gates and let the tool map to the spare type gates, Place and Route tool should map the spare type gates to the exact spare gate instances.

The setup for this mode:

A use case for Metal Only ECO mode 1 can be found in

gof_gui_metal_eco_mode_1.pdf

4.3.2.2 Metal ECO, mode 2

User can add any type of gates and let the tool map to the exact physically existing spare gate instances.

The setup for this mode:

A use case for Metal Only ECO mode 2 can be found in

gof_gui_metal_eco_mode_2.pdf

4.3.2.3 Metal ECO, mode 3

User can add only spare type gates and let the tool map to the exact spare gate instances.

The setup for this mode:

A use case for Metal Only ECO mode 3 can be found in

gof_gui_metal_eco_mode_3.pdf

4.3.2.4 Metal ECO, mode 4

User can pick the exact spare gate instances, and connect and disconnect up the instances in ECO.

The setup for this mode:

A use case for Metal Only ECO mode 4 can be found in

gof_gui_metal_eco_mode_4.pdf

4.4 LayoutViewer

LayoutViewer window displays partial physical placements. The circuit drawn on the schematic can be highlighted on LayoutViewer. It has full interactivity with GofTrace. It requires physical design files including DEF and LEF files to be loaded.

img

Figure 28: LayoutViewer Window

4.4.1 File Menu

4.4.1.1 Capture in PDF

This command captures the current LayoutViewer display to PDF file. PDF is only supported in Linux Platform. In Windows Platform, the captured display is saved in PostScript format.

4.4.1.2 Exit

Exit LayoutViewer.

4.4.2 Commands Menu

4.4.2.1 Clear Circuit Markers

Clear circuit markers which can be created by Drag-And-Drop from GofTrace Partial Schematic.

4.4.2.2 Clear Search Markers

Clear search markers which are those highlighted cells matching the searching string in search entry.

4.4.2.3 New Schematic

When cells or markers are selected in LayoutViewer, this command can launch a schematic with selected instances on it.

4.4.3 OptionsMenu

4.4.3.1 Show Grid

This option shows grid on LayoutViewer.

4.4.3.2 Show Instance

This option shows instance name on LayoutViewer. Zoom in scale should be large enough to show instance names.

4.4.3.3 Show Module

This option shows module name on LayoutViewer. Zoom in scale should be large enough to show module names.

4.4.3.4 Setup

LayoutViewer setups which include maximum search matching number and placement display zone area size.

4.4.4 Help Menu

4.4.4.1 Help on LayoutViewer

Visit NanDigits web site for Gates On the Fly manual section LayoutViewer.

4.4.5 LayoutViewer Pop Menu

Click mouse-right-button to pop up the menu.

4.4.5.1 Clear Circuit Markers

Clear circuit markers which can be created by Drag-And-Drop from GofTrace Partial Schematic .

4.4.5.2 Clear Searching Markers

This command clears searching markers which were activated by search function.

4.4.5.3 Copy Selected to

This command copies the selected gates to the following destination:

4.4.6 Keyboard and mouse combination

4.4.6.1 Ctrl key to measure length

Press 'Ctrl' key and move mouse, the Cursor Coordination displays the length cursor moves in unit of 'um'.

4.4.6.2 Shift key to select multiple markers

Press 'Shift' key and press mouse-left-button, move mouse to draw a virtual rectangle. When release the mouse-left-button, those markers in the virtual rectangle are all highlighted. Click mouse-right-button to pop menu, those selected instances can be sent to other schematics or GofViewer the netlist view window by 'Copy Selected to' command.

4.4.7 Mouse operations

4.4.8 Select color buttons

Click color buttons in 'Select color:' bar to select the current color. 'Select Color:' string changes to the current selected color. Any new Circuit Markers and Search Markers have this color.

4.4.9 Search function

Type search string in Search Entry to highlight the leaf instances matching the string on the LayoutViewer. The search string is in 'path/instance' string format, separated by '/'. Wildcard can be used in path and instance names. The markers have the color selected in 'Select color' bar.

The search string takes these options:

Examples:

'u_rtc/*' : Search leaf instances in hierarchy 'u_rtc'.
'* -hier -type nand': Search all leaf instances with 'nand' type in the design.
'u_clk/* -hier': Search all leaf in hierarchy 'u_clk' and its sub-hierarchies.

下一章 附录A

位置:文档/GOF用户手册/第四章 GUI模式

更多文档:文档目录


微信公众号

LinkedIn

Nandigits.com 美国官网 | Nandigits.cn 中国官网
© 2021 Nandigits Design Automation. 版权所有。